SUGGESTION BOX (for Admin action)

How to register at Cluesforum / General administrative topics / and things that every member must read
Post Reply
hoi.polloi
Administrator
Posts: 5061
Joined: Sun Nov 14, 2010 7:24 pm

Re: SUGGESTION BOX (for Admin action)

Unread post by hoi.polloi » Thu Jan 18, 2018 3:55 am

Alright, everyone. Phhewww! I got through the latest suggestions. I hope you are happy, animus! Now, when is our translation of the Historical Development coming?
:P

Just kidding. I know that will be a massive document to bother translating.

anonjedi2, I've completed your latest audits up to page 39 of the I$$ thread. Thank you both for all you do.

PianoRacer
____
Posts: 61
Joined: Thu Nov 10, 2016 1:13 am

Re: SUGGESTION BOX (for Admin action)

Unread post by PianoRacer » Thu Jan 18, 2018 11:00 pm

hoi.polloi » January 17th, 2018, 10:55 pm wrote:Thank you both for all you do.
Seconded and I'd also like to thank you, Hoi, for your time and efforts maintaining the quality of the forum. If you should find yourself in Minnesota when I am there (I spend the summers there, mosquitoes be damned) I'd love to buy you a beer!

I still think SSL should be implemented, but I am not sure how to help with that effort. If you decide to take another stab at it, I'd be happy to offer guidance/support. Just let me know.

--PianoRacer

Seneca
Member
Posts: 458
Joined: Wed Oct 21, 2009 2:36 pm
Contact:

Re: SUGGESTION BOX (for Admin action)

Unread post by Seneca » Fri Mar 30, 2018 9:58 am

I can't find how to change my e-mail address or even see what e-mail address I registered.

ADMIN NOTICE (simon): Dear Seneca, I've sent you an e-mail about the issue - should be fixed now.

Observer
Banned
Posts: 167
Joined: Sat Feb 07, 2015 12:47 am
Location: Interwebs

Re: SUGGESTION BOX (for Admin action)

Unread post by Observer » Wed Jun 27, 2018 1:19 am

Instead of their only location being elsewhere, it sure would be nice to have all of your 19 videos hosted here and/or here Simon?

hoi.polloi
Administrator
Posts: 5061
Joined: Sun Nov 14, 2010 7:24 pm

Secure site: Good news and bad news

Unread post by hoi.polloi » Fri Jul 13, 2018 4:43 pm

Dear CluesForum,

Last week, we successfully implemented security to the site (https) which encrypts data and ostensibly protects people. I am not buying it since I think there are probably very strong hacks (in possession by intelligence agencies I'd assume?) that can get around such site behavior.

But why have we done this?

In the near future it's possible that The Governmoogle and other establishment search engines will begin hardcore blocking of non-SSL/TSL web sites. So as a preemptive measure to preserve the small trickle of traffic we have, we have added this. (After trying a few methods I got it to work!)

However, there may be a few consequences because the forum was not built under SSL and it may cause the occasional bug. If you notice any weird behavior, please let us know and we'll try to look into it when we can.

Thank you for your patience!

fbenario
Member
Posts: 2231
Joined: Fri Oct 23, 2009 1:49 am
Location: Atlanta, GA
Contact:

Re: SUGGESTION BOX (for Admin action)

Unread post by fbenario » Sat Jul 14, 2018 1:29 am

I wondered what was going on. For the last week when I click Login I get the following message:

"This site can't provide a secure connection

www.cluesforum.info sent an invalid response

Try running Windows Network Diagnostics

ERR_SSL_PROTOCOL_ERROR"


I've had to click the link at the top of septemberclues.info to access the forum.

hoi.polloi
Administrator
Posts: 5061
Joined: Sun Nov 14, 2010 7:24 pm

Re: SUGGESTION BOX (for Admin action)

Unread post by hoi.polloi » Sat Jul 14, 2018 3:27 am

Thanks fbenario. I get some weird error occasionally which is completely different. If you don't mind please sending me your browser and operating system info in an e-mail I will try to get to the bottom of this. It may take a while and once more thank you for your help and patience. Just to be clear, this is not when you go to the login page but when you hit the LOGIN button after you enter your credentials, correct?

PianoRacer
____
Posts: 61
Joined: Thu Nov 10, 2016 1:13 am

Re: SUGGESTION BOX (for Admin action)

Unread post by PianoRacer » Sat Jul 14, 2018 3:33 am

fbenario,

What URL were you attempting to access when you got that error? Were you clicking a link or accessing a bookmark?

For myself, for some very strange reason, after I log in and click the "Return to Previous Page" button, it adds a specific port 80 to the https link:

https://cluesforum.info:80/posting.php? ... =32&t=1608

As a result, and unsurprisingly (due to trying to access an https URL on port 80, which is default for http) I get a "Secure Connection Failed" message, specifically: SSL_ERROR_RX_RECORD_TOO_LONG.

When I remove the :80 from the URL, it works fine - so my advice is to figure out what mechanism is adding that :80 to the URL and nix it.

Good work on implementing SSL, imperfect as it may be, and good luck on resolving the issues!

P.S. Apologies for not making it to ALCON today. My kids came down with a moderate illness and I was needed here. I still hope to make it down tomorrow and not let my $80 registration fee go to waste. I hope things are going well there - give Phil Plait a kick in the shin for me.

All the best,
-PR

hoi.polloi
Administrator
Posts: 5061
Joined: Sun Nov 14, 2010 7:24 pm

Re: SUGGESTION BOX (for Admin action)

Unread post by hoi.polloi » Sat Jul 14, 2018 4:01 am

Health takes priority. Glad you didn't come today either since I was resting from the convention.

That switch to the right https port sure worked spectacularly. Thanks for pointing me in the right direction. fbenario, please see if that fixed your LOGIN button issues.

fbenario
Member
Posts: 2231
Joined: Fri Oct 23, 2009 1:49 am
Location: Atlanta, GA
Contact:

Re: SUGGESTION BOX (for Admin action)

Unread post by fbenario » Sat Jul 14, 2018 11:11 pm

I use Chrome, and click Login at the bottom of the homepage every day. Last night after posting that I had gotten that SSL error message for a week I tried a few fixes specific to Chrome for SSL error problems that I found here:

https://www.ssl2buy.com/wiki/how-to-fix ... ocol-error

I think I did numbers 3 and 4.

Right now I had no problem entering the forum as usual, clicking on Login at the bottom of the home page, with no 'SSL error' messages. What I don't know is if today's smooth login results from my Chrome 'SSL error' fixes last night or any programming change by Hoi today.

anonjedi2
Member
Posts: 726
Joined: Mon Dec 31, 2012 5:50 am

Re: THE "CHATBOX"

Unread post by anonjedi2 » Sat Oct 06, 2018 12:40 am

I received this warning from Google for the first time ever, visiting CluesForum today. <_<

Image

SacredCowSlayer
Administrator
Posts: 654
Joined: Sat Sep 05, 2015 9:44 pm

Re: THE "CHATBOX"

Unread post by SacredCowSlayer » Sat Oct 06, 2018 12:56 am

anonjedi2 » October 5th, 2018, 7:40 pm wrote:I received this warning from Google for the first time ever, visiting CluesForum today. <_<

Image
Yes, there was a technical issue that arose briefly this afternoon.

The site is secure. I had to “tell” my computer to “allow” access here after it got resolved.

It’s all good.

Thanks,

SCS

patrix
Member
Posts: 494
Joined: Wed Dec 14, 2016 10:24 am

Re: THE "CHATBOX"

Unread post by patrix » Sat Oct 06, 2018 6:03 am

SacredCowSlayer » October 6th, 2018, 1:56 am wrote:
anonjedi2 » October 5th, 2018, 7:40 pm wrote:I received this warning from Google for the first time ever, visiting CluesForum today. <_<

Image
Yes, there was a technical issue that arose briefly this afternoon.

The site is secure. I had to “tell” my computer to “allow” access here after it got resolved.

It’s all good.

Thanks,

SCS
This is a big problem affecting all users. Google has now made SSL certificate mandatory for all sites and Cluesforum does not have one or it isn't valid?

Every time I load a page from Cluesforum on my Android tablet, I get the nag screen above and are not able to switch it off permanently.

You should be able to get an SSL certificate for free at https://letsencrypt.org or renew the one you have.

To me this is obviously a way to implement internet censorship. Have all sites implement this technology and have all webbrowsers make it mandatory for "security reasons".

Then when it's established it's time for the bait and switch. Revoke certificates for sites that do not support "human values" and it will be very hard for people to access them because they will see the message above, and in the future sites without a certificate will probably not be accessible at all.

Edit: I get the same thing on my phone, so it's definitely an issue with Cluesforums SSL certificate.

pov603
Member
Posts: 836
Joined: Thu Jun 30, 2011 8:02 pm

Re: THE "CHATBOX"

Unread post by pov603 » Sat Oct 06, 2018 10:54 am

I’ve gotten the same thing.

patrix
Member
Posts: 494
Joined: Wed Dec 14, 2016 10:24 am

Re: THE "CHATBOX"

Unread post by patrix » Sat Oct 06, 2018 12:47 pm

pov603 » October 6th, 2018, 11:54 am wrote:I’ve gotten the same thing.
It seems the certificate for cluesforum.info expired on October 5th and needs to be renewed

Post Reply